Monday, May 21, 2012

Problem with Glassfish

When I installed Eclipse for EE developers and Glassfish v3. The IDE detected the server and registered it, but when it comes to run the applications I get the following error message:

GlassFish v3 requires a JDK 1.6 and not a JRE. Please add/select the correct JDK in the Server properties 'Runtime Environment' section.

Then I do research for this problem I find because I am using a new computer so I forgot to install JDK on my computer then I fix the problem by:

  1.  grab just the jdk from
  2.  This is where the error message kinda foobars ya... 
    - Get eclipse started, ignore the message. 
    - Go to Window>Preferences 
    - Then under +Java+Installed JREs hit Add.
    - Select 'Standard VM' then Next
    - JRE Home = C:\Program Files\Java\jdk1.6.XXXX the rest should fill in automagically. Hit Finish.
    - MOST IMPORTANT!!! Click the check box back in the Preferences Window for the new jdk runtime...I don't know why it's necessary, but it definitely is..

No comments:

Post a Comment